MuPAD® notebooks will be removed in a future release. Use MATLAB® live scripts instead.

MATLAB live scripts support most MuPAD functionality, though there are some differences. For more information, see Convert MuPAD Notebooks to MATLAB Live Scripts.

You can insert a link to a particular location in the same notebook or in some other MuPAD® notebook. This location is called a link target. First, use the following procedure to create a link target:

  1. Open the notebook in which you want to create a link target.

  2. Select the part of the notebook that you want to use as a link target. You can select any object in a notebook, except for output regions.

  3. Select Insert>Link Target to declare the selected part of a notebook as a link target. Alternatively, use the context menu.

  4. In the Create Link Target dialog box, type the name of the link target.

  5. Save the notebook that contains the link target.

To associate a link with a link target:

  1. Open the notebook in which you want to insert a link. This notebook can be the same one where you defined the link target, or it can be any other notebook.

  2. Select the part of a notebook where you want to create a link.

  3. Select Insert>Link from the main menu or use the context menu.

  4. In the Create Hyperlink dialog box, select MuPAD Document and the name of the notebook that you want to link to. The Targets list displays all link targets available in the selected notebook.

  5. In the Targets list, select the link target that you want to use. If you want to create a link to the top of the notebook, select TOP.

To insert a link to a MuPAD notebook interactively (without choosing and naming the target in advance):

  1. Open the notebook in which you want to insert a link.

  2. Select the part of a notebook where you want to insert the link.

  3. From the context menu select Insert link interactively.

  4. The following dialog box appears. To continue creating a link, click OK.

  5. Open the notebook where you want to insert the link target. If you create a new notebook, save it before proceeding.

  6. Select the part of the notebook to which you want to link.

  7. Right-click the selected part. From the context menu, select Interactive link to this point.

To insert a link to any file on your computer:

  1. Select the part of a notebook where you want to insert a link.

  2. Select Insert>Link from the main menu or use the context menu.

  3. In the Create Hyperlink dialog box select Existing File.

  4. Select the file you want to refer to. To select the file, enter the file name in the Link to field or choose the file from the history list. Alternatively, click the Open File button , and then browse for the file.

To insert a link to an Internet address:

  1. Select the part of the notebook where you want to insert a link.

  2. Select Insert>Link from the main menu or use the context menu.

  3. In the Create Hyperlink dialog box, select Internet.

  4. Type an Internet address and click OK. For example, insert a link to the Web page.

To insert a link to an e-mail address, type mailto: before the address.

To edit a link:

  1. Select the link that you want to edit.

  2. Select Edit>Link from the main menu or use the context menu.

  3. In the Edit Hyperlink dialog box, edit the link. You can change the display text or the link target or both.

To delete a link:

  1. Select the link that you want to delete.

  2. Right-click to open the context menu.

  3. Select Remove Link

Alternatively, you can use the Edit Hyperlink dialog box to delete a link. To delete a link by using the Edit Hyperlink dialog box:

  1. Select the link that you want to edit.

  2. Select Edit>Link from the main menu or use the context menu.

  3. In the Edit Hyperlink dialog box, click the Remove Link button.

  4. Click OK.

If the list of link targets is very long, finding the correct link target can be difficult. To make this list shorter, delete link targets that you do not use. To delete a link target:

  1. Find the link target in a notebook. To highlight all link targets in a notebook, select View>Highlight Link Targets.

  2. Select the link target that you want to delete.

  3. Select Insert>Link Target from the main menu or use the context menu.

  4. In the Edit Link Target dialog box, click Delete.