Error Updating Model Reference SIM Targets (an error occured during the call to make)

21 views (last 30 days)
Hello allm
I have two big separated models on simulinks, each of them can be simulated without any problems on matlab 2018B. Now I tried to integrate them into one massive models. Each of those models consists of many subsystems and codes. After I integrate them, I tried to make an adjustment to the models so they can be performed flawlessly.
when I simulate it, an "updating model reference SIM target (1 of 5)" was performed and it took 1.5 hour only for the first one and it ended with an error stated " an error occurred during the call to make, is not recognized as an internal or external command" , as shown on the attachment.
I tried actually to uncomment that subsystem to check if the other subsystems can still be performed, and it ended up perfect, which mean the simulation can be run. The problematic subsystem actually consists of signals which connected only into 3D lookup tables.
does anyone has idea or solution to encounter this problem?
Thank you

Accepted Answer

Mark McBroom
Mark McBroom on 19 Sep 2021
The error is coming from the mingw compiler that Simulink is using to compile/link the code generated from model "machine". Do you have access to Visual Studio? If so, use the mex -setup command to switch compilers to see if the code will compile/link with Vis Studio.

Sign in to comment.

More Answers (0)


Find more on Simulink Coder in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by