MATLAB Answers

Can't write Raspberry Pi firmware to MicroSD card using Simulink wizard on Mac

4 views (last 30 days)
Eric
Eric on 3 Sep 2020
Commented: Walter Roberson on 3 Sep 2020
I'm having an issue writing the Raspberry Pi firmware to a MicroSD card using the Simulink wizard on Mac. I get the error message below.
I've tried different MicroSD cards.
I've tried formatting the MicroSD card.
I've tried deleting the "img_writer_log.txt" file, which is what another Matlab Answer suggested.
On Windows, people say to right-click on the Matlab icon, and then "Run as Administrator", but I'm not sure how to do that on a Mac.
I'm running out of ideas, and need to get this going soon, so any help is much appreciated. Thanks in advance!

  4 Comments

Show 1 older comment
Eric
Eric on 3 Sep 2020
Did you try formatting the MicroSD card? Good luck with it. Please let me know if you get through the process.
Walter Roberson
Walter Roberson on 3 Sep 2020
Yup, I was referred to the appropriate industry tool to format the card. Which I already knew was a red herring, as the raspian tool was also refusing to recognize the microSD boot card that came with the raspberry.
Walter Roberson
Walter Roberson on 3 Sep 2020
I do not know if the software still works these days, but historically "Pseudo 1.2.3" by Brian Hill was useful for dragging and dropping an application to run it as super user on Mac.

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by