PID block has underspecified signal dimensions, ALL groundblocks affected

3 views (last 30 days)
Im building a simulink model and would like to use the PID block to control the system. However when i run the simulation i recieve the following warning:
" •Block '¨~/PID controllers/PID Controller1/Ground_D' 'Output Port 1' has been set to [1]."
This warning is generated for each and every ground block inside the PID, which is fed with a single error signal formatted as double.
I've tried every suggestion from the software except simply removing the warning, is this a known error or is there something to do about it?
I'm running matlab R2020b (
and simulink ver 10.2
Thank you in advance!

Answers (1)

Fangjun Jiang
Fangjun Jiang on 6 Oct 2022
I saw this quite often. I think the cause is that the Ground block doesn't have its Dimension (or size) info defined, not even a default value. The warning message says Simulink interprets its size as [1].
For numerical signal, replacing it with a Constant block with zero value usually resolves it. In terms of data value, the Ground block is read as zero.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by