Borrar filtros
Borrar filtros

No visualization of Mechanics Explorer when starting Simulink from GUI

15 visualizaciones (últimos 30 días)
I guess the title already says it all.
I built a simmechanics multibody model of a robot in Simulink which is visualized when starting the Simulation directly from Simulink.
But when I try starting the simulation from a GUI (Matlab App-Designer) with the command:
%%Start Simulation
simOut = sim('Modell_Roboter_Tisch_InverseKin.slx','ReturnWorkspaceOutputs','on');
assignin('base', 'simOut', simOut) %Writes simulation output to base workspace
there is no visualization of the robot. The Mechanics Explorer windows just stays grey:
I already tried zooming out/in, enabling all components, etc.
Hope you guys can help me with this problem.
Thanks in advance!
  2 comentarios
Timo Schmid
Timo Schmid el 8 de Abr. de 2020
Unfortunately I didn't find a solution.
From the one day to another it just worked again as before... But I still don't know what the problem was - sorry.

Iniciar sesión para comentar.

Respuestas (2)

Damian Keretic
Damian Keretic el 7 de Abr. de 2020
Same problem here. Could someone help?

Kim Bostroem
Kim Bostroem el 26 de Mzo. de 2021
I have the same problem. For me, the workaround is to have the model file (.slx) open in the background. The problem appeared when I updated to Matlab 2020b. I hope this bug is fixed in the next update.


Más información sobre Applications en Help Center y File Exchange.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by