Product Requirements & Platform Availability for AUTOSAR Blockset

Supported Platforms

Mac, Windows, Linux

Product Requirements

  • Requires MATLAB
  • Requires Simulink
  • Fixed-Point Designer required for workflows with non-standard DataConstr data types
  • Embedded Coder required to generate AUTOSAR code and export ARXML files
  • System Composer required to create AUTOSAR Architecture models

Introduced in R2019a

View requirements for another product: