Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Introducción al diseñador de filtros

Para abrir la aplicación, escriba en el símbolo del sistema.Diseñador de filtros

filterDesigner
MATLAB®

La aplicación se abre con el panel filtro de diseño mostrado.Diseñador de filtros

Tenga en cuenta que cuando se abre, no está habilitado.Diseñador de filtrosDesign Filter Usted debe hacer un cambio al diseño del filtro predeterminado para habilitar.Design Filter Esto es cierto cada vez que desea cambiar el diseño del filtro. Cambia los elementos del botón de radio o los elementos de menú desplegables, como los que están bajo o habilitan inmediatamente. Response TypeFilter OrderDesign Filter Los cambios en las especificaciones en los cuadros de texto, como, y requieren que haga clic fuera del cuadro de texto para habilitar.FsFpassFstopDesign Filter

Elegir un tipo de respuesta

Puede elegir entre varios tipos de respuesta:

  • Pasabajos

  • Coseno elevado

  • Pasa-altos

  • Bandpass

  • Supresión

  • Diferenciador

  • Multibanda

  • El transformador Hilbert

  • Magnitud arbitraria

Hay disponibles tipos de respuesta adicionales si tiene software instalado.DSP System Toolbox™

Nota

No todos los métodos de diseño de filtro están disponibles para todos los tipos de respuesta. Una vez que elija su tipo de respuesta, esto puede restringir los métodos de diseño de filtro disponibles para usted. Los métodos de diseño de filtro que no están disponibles para un tipo de respuesta seleccionado se quitan de la región del método de diseño de la aplicación.

Elegir un método de diseño de filtro

Puede usar el método de diseño de filtro predeterminado para el tipo de respuesta que ha seleccionado, o puede seleccionar un método de diseño de filtro de los métodos FIR e IIR disponibles enumerados en la aplicación.

Para seleccionar el algoritmo Remez para computar los coeficientes del filtro FIR, seleccione el botón de radio y elija de la lista de métodos.FIREquiripple

Establecer las especificaciones de diseño del filtro

Visualización de especificaciones de filtro

Las especificaciones de diseño del filtro que puede establecer varían según el tipo de respuesta y el método de diseño. La región de visualización ilustra las especificaciones del filtro al seleccionar Analysis > Filter Specifications o al hacer clic en el botón de la barra de herramientas.Filter Specifications

También puede ver las especificaciones del filtro en la gráfica de magnitud de un filtro diseñado seleccionando View > Specification Mask.

Orden de filtro

Tiene dos opciones mutuamente excluyentes para determinar el orden de filtro al diseñar un filtro de equiripple:

  • :Specify order Introduzca el orden de filtro en un cuadro de texto.

  • :Minimum order El método de diseño del filtro determina el filtro de orden mínimo.

Tenga en cuenta que las opciones de especificación de orden de filtro dependen del método de diseño de filtro que elija. Es posible que algunos métodos de filtro no tengan ambas opciones disponibles.

Opciones

Las opciones disponibles dependen del método de diseño de filtro seleccionado. Sólo los métodos de diseño de la ventana FIR y la Equiondulación de abeto tienen opciones configurables. Para FIR Equiripple, la opción es a.Density Factor Consulte para obtener más información.firpm Para la ventana FIR las opciones son, selección, y para las siguientes ventanas, un parámetro configurable:Scale PassbandWindow

Ventana

Parámetro

Chebyshev ()chebwin

Atenuación sidelobe

Gaussiano ()gausswin

Alfa

Kaiser ()kaiser

Beta

Taylor ()taylorwin

El nivel nbar y Sidelobe

Tukey ()tukeywin

Alfa

Definido por el usuario

Nombre de la función, parámetro

Puede ver la ventana en la herramienta de visualización de ventanas () haciendo clic en el botón.wvtoolView

Especificaciones de frecuencia del filtro de paso de banda

Para un filtro de paso de banda, puede establecer

  • Unidades de frecuencia:

    • Hz

    • Khz

    • Mhz

    • Normalizado (0 a 1)

  • Frecuencia de muestreo

  • Frecuencias de banda de paso

  • Las frecuencias de banda

Especifique la banda de paso con dos frecuencias. La primera frecuencia determina el borde inferior de la banda de paso, y la segunda frecuencia determina el borde superior de la banda de paso.

Del mismo modo, se especifica la banda de detención con dos frecuencias. La primera frecuencia determina el borde superior de la primera banda de suspensión, y la segunda frecuencia determina el borde inferior de la segunda banda de suspensión.

Especificaciones de magnitud del filtro de paso de banda

Para un filtro de paso de banda, puede especificar las siguientes características de respuesta de magnitud:

  • Unidades para la respuesta de magnitud (dB o lineal)

  • La ondulación de passband

  • Atenuación de la banda de suspensión

Calcular los coeficientes de filtro

Ahora que ha especificado el diseño del filtro, haga clic en el botón para calcular los coeficientes del filtro.Design Filter

Nota

El botón está desactivado una vez que haya calculado los coeficientes para el diseño del filtro.Design Filter Este botón se activa de nuevo una vez que realice los cambios en las especificaciones del filtro.

Analizando el filtro

Mostrar las respuestas del filtro

Puede ver las siguientes características de respuesta de filtro en la región de visualización o en una ventana independiente.

  • Respuesta de magnitud

  • La respuesta de fase

  • Las respuestas de magnitud y fase

  • Respuesta de retardo de grupo

  • Respuesta de retardo de fase

  • Respuesta impulsiva

  • Respuesta de paso

  • Parcela de polo cero

  • Respuesta de fase cero: disponible en el menú contextual del eje en una gráfica de respuesta de magnitud o magnitud y fase.y

Nota

Si tiene instalado un producto, hay otros dos análisis disponibles: estimación de la respuesta de magnitud y potencia de ruido de redondeo.DSP System Toolbox Estos dos análisis son los únicos que utilizan los componentes internos del filtro.

Para obtener descripciones de las respuestas anteriores y sus botones de barra de herramientas asociados y otros botones de la barra de herramientas, consulte.Diseñador de filtrosfvtool

Puede mostrar dos respuestas en el mismo trazado seleccionando Analysis > Overlay Analysis y seleccionar una respuesta disponible. Se agrega un segundo eje al lado derecho de la gráfica de respuesta.y (Tenga en cuenta que no todas las respuestas pueden ser superpuestas entre sí.)

También puede mostrar los coeficientes de filtro y la información detallada del filtro en esta región.

Para todos los métodos de análisis, excepto la respuesta de fase cero, puede acceder a ellos desde el menú, el cuadro de diálogo parámetros de análisis del menú contextual o mediante los botones de la barra de herramientas.Analysis Para la fase cero, haga clic con el botón derecho en el eje del trazado y seleccione en el menú contextual.yZero-phase

Puede superponer las especificaciones de filtro en la gráfica de magnitud seleccionando View > Specification Mask.

Uso de consejos de datos

Puede hacer clic en la respuesta para agregar sugerencias de datos de trazado que muestren información sobre puntos concretos de la respuesta.

Para obtener información sobre el uso de sugerencias de datos, consulte.Explore de forma interactiva los datos trazados (MATLAB)

Dibujar máscaras espectrales

Para agregar máscaras espectrales o líneas de área de rechazo a la gráfica de magnitud, haga clic en View > User-defined Spectral Mask.

La máscara se define mediante un vector de frecuencia y un vector de magnitud. Estos vectores deben tener la misma longitud.

  • : Seleccione esta casilla para activar la visualización de la máscara.Enable Mask

  • — Seleccione para normalizar la frecuencia entre 0 y 1 en el rango de frecuencias visualizado.Normalized Frequency

  • : Permite introducir valores de frecuencia de vector de eje.Frequency Vectorx

  • : Permite seleccionar las unidades de magnitud deseadas.Magnitude Units Estas unidades deben coincidir con las unidades utilizadas en la gráfica de magnitud.

  • : Permite introducir valores de magnitud de vector de eje.Magnitude Vectory

Cambiar la frecuencia de muestreo

Para cambiar la frecuencia de muestreo del filtro, haga clic con el botón derecho en cualquier trazado de respuesta de filtro y seleccione en el menú contextual.Sampling Frequency

Para cambiar el nombre del filtro, escriba el nuevo nombre.Filter name (En, si tiene varios filtros, seleccione el filtro deseado y, a continuación, escriba el nuevo nombre.)fvtool

Para cambiar la frecuencia de muestreo, seleccione la unidad deseada e introduzca la frecuencia de muestreo en.UnitsFs (Para cada filtro en, puede especificar una frecuencia de muestreo diferente o puede aplicar la frecuencia de muestreo a todos los filtros.)fvtool

Para guardar los parámetros mostrados como los valores predeterminados que se usarán cuando o FVTool esté abierto, haga clic en.Diseñador de filtrosSave as Default

Para restaurar los valores predeterminados, haga clic en.Restore Original Defaults

Mostrar la respuesta en FVTool

Para mostrar las características de respuesta del filtro en una ventana independiente, seleccione View > Filter Visualization Tool (disponible si cualquier análisis, excepto las especificaciones del filtro, está en la región de visualización) o haga clic en el botón.Full View Analysis Esto inicia la herramienta de visualización de filtros ().fvtool

Nota

Si las especificaciones de filtro se muestran en la región de visualización, al hacer clic en el botón de la barra de herramientas se inicia una ventana de figura en lugar de FVTool.Full View AnalysisMATLAB El elemento de menú asociado es, que solo se habilita si se muestran las especificaciones del filtro.Print to Figure

Puede utilizar esta herramienta para anotar el diseño, ver otras características de filtro e imprimir la respuesta del filtro. Puede vincular y FVTool para que los cambios realizados en se reflejen inmediatamente en FVTool.Diseñador de filtrosDiseñador de filtros Consulte para obtener más información.fvtool

Edición del filtro mediante el editor de polos/cero

Visualización de la gráfica pole-Zero

Puede editar los coeficientes de un filtro diseñado o importado moviendo, eliminando o agregando polos y/o ceros utilizando el panel Editor de polos/cero.

Nota

No se puede generar código (MATLABFile > Generate MATLAB code) si el filtro se diseñó o editó con el editor de polos/cero.

No puede mover los polos y ceros cuantizados. Sólo se pueden desplazar los polos de referencia y los ceros.

Haga clic en el botón de la barra lateral o seleccionePole/Zero Editor Edit > Pole/Zero Editor para mostrar el panel del editor de polos/cero.

Los polos se muestran usando símbolos x y los ceros se muestran usando símbolos o.

Cambio de la gráfica pole-Zero

Los botones de modo de trazado se encuentran a la izquierda de la gráfica Polo/cero. Seleccione uno de los botones para cambiar el modo de la gráfica de polo/cero. El editor de polos/cero tiene estos botones de izquierda a derecha:,,, y.Move Pole/ZeroAdd PoleAdd ZeroDelete Pole/Zero

Los siguientes parámetros y controles de trazado se encuentran a la izquierda del trazado de polo/cero y por debajo de los botones del modo de trazado.

  • — factor para compensar el polo (s) del filtro y el cero (s) ganaFilter gain

  • — unidades (o) del polo seleccionado o de ceroCoordinatesPolarRectangular

  • — Si se seleccionan las coordenadas polares, la magnitud del polo seleccionado o el ceroMagnitude

  • — Si se seleccionan las coordenadas polares, el ángulo del polo (s) seleccionado o el cero (s)Angle

  • — Si se seleccionan coordenadas rectangulares, componente real de los polos seleccionados o cero (s)Real

  • — Si se seleccionan coordenadas rectangulares, el componente imaginario del polo seleccionado o el ceroImaginary

  • — para los filtros multisección, el número de la sección actualSection

  • : crea un polo conjugada correspondiente o cero o selecciona automáticamente el polo conjugada o cero si ya existe.Conjugate

  • : actualiza inmediatamente la respuesta de magnitud mostrada cuando se agregan, mueven o eliminan postes o ceros.Auto update

el Edit > Pole/Zero Editor tiene elementos para seleccionar varios polos/ceros, para invertir y reflejar polos/ceros, y para eliminar, escalar y rotar polos/ceros.

  • Cuando se selecciona un polo o cero de un par conjugada, la casilla de verificación y el conjugada se seleccionan automáticamente.Conjugate

Convertir la estructura de filtro

La conversión a una nueva estructura

Puede utilizar Edit > Convert Structure para convertir el filtro actual en una nueva estructura. Todos los filtros se pueden convertir en las siguientes representaciones:

  • Forma directa I

  • Forma directa II

  • Forma directa I transpuesto

  • Forma directa II transpuesta

  • Lattice ARMA

Nota

Si tiene instalado un producto, verá estructuras adicionales en el cuadro de diálogo convertir estructura.DSP System Toolbox

Además, las siguientes conversiones están disponibles para determinadas clases de filtros:

  • Los filtros FIR de fase mínima se pueden convertir en fase mínima de celosía

  • Los filtros FIR de fase máxima se pueden convertir en Lattice fase máxima

  • Los filtros allpass se pueden convertir en Lattice allpass

  • Los filtros IIR se pueden convertir a Lattice ARMA

Nota

La conversión de un filtro estructura a otra puede producir un resultado con diferentes características que el original. Esto se debe a la aritmética de precisión finita del equipo y a las variaciones en los cálculos de redondeo de la conversión.

Por ejemplo:

  • Seleccione Edit > Convert Structure para abrir el cuadro de diálogo convertir estructura.

  • Seleccione en la lista de estructuras de filtro.Direct-formI

La conversión a secciones de segundo orden

Puede utilizar Edit > Convert to Second-Order Sections para almacenar la estructura de filtro convertida como una colección de secciones de segundo orden en lugar de como una estructura monolítica de orden superior.

Nota

Las siguientes opciones también se utilizan para Edit > Reorder and Scale Second-Order Sections, que se utiliza para modificar una estructura de filtro SOS.

Las siguientes opciones están disponibles al convertir una estructura de forma directa II solamente:Scale

  • predeterminadoNone

  • (L-2L2 norma

  • (L-infinityL norma

El (o) determina el orden de las secciones de segundo orden.DirectionUpDown El orden óptimo cambia dependiendo de la opción seleccionada.Scale

Por ejemplo:

  • Seleccione Edit > Convert to Second-Order Sections para abrir el cuadro de diálogo convertir en SOS.

  • Seleccione en el menú paraL-infinityScaleL escala de norma.

  • Dejar como opción.UpDirection

Nota

Para convertir de secciones de segundo orden en una sola sección, utilice Edit > Convert to Single Section.

Exportar un diseño de filtro

Exportación de coeficientes u objetos al espacio de trabajo

Puede guardar el filtro como variables de coeficientes de filtro o como variable de objeto de filtro. Para guardar el filtro en el espacio de trabajo:MATLAB

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.WorkspaceExport To

  3. Seleccione en el menú para guardar los coeficientes de filtro o seleccione para guardar el filtro en un objeto de filtro.CoefficientsExport AsObjects

  4. Para los coeficientes, asigne nombres de variables utilizando los cuadros de texto (para filtros FIR) o (para filtros IIR) o (para filtros IIR en forma de sección de segundo orden) en la región nombres de variables.NumeratorNumeratorDenominatorSOS MatrixScale Values

    Para los objetos, asigne el nombre de la variable en el cuadro de texto.Discrete Filter Si tiene variables con los mismos nombres en el área de trabajo y desea sobrescribirlas, active la casilla de verificación.Overwrite Variables

  5. Haga clic en el botón.Export

Exportar coeficientes a un archivo ASCII

Para guardar los coeficientes de filtro en un archivo de texto,

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.CoefficientsFile(ASCII)Export To

  3. Haga clic en el botón.Export Los coeficientes de filtro de exportación a. FCF aparece el cuadro de diálogo.

  4. Elija o escriba un nombre de archivo y haga clic en el botón.Save

Los coeficientes se guardan en el archivo de texto que especificó y el editor se abre para mostrar el archivo.MATLAB El archivo de texto también contiene comentarios con el número de versión, el número de versión y la información de filtro.MATLABSignal Processing Toolbox™

Exportar coeficientes u objetos a un archivo MAT

Para guardar los coeficientes de filtro o un objeto de filtro como variables en un archivo MAT:

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.MAT-fileExport To

  3. Seleccione en el menú para guardar los coeficientes de filtro o seleccione para guardar el filtro en un objeto de filtro.CoefficientsExport AsObjects

  4. Para los coeficientes, asigne nombres de variables utilizando los cuadros de texto (para filtros FIR) o (para filtros IIR) o (para filtros IIR en forma de sección de segundo orden) en la región nombres de variables.NumeratorNumeratorDenominatorSOS MatrixScale Values

    Para los objetos, asigne el nombre de la variable en el cuadro de texto o.Discrete Filter (Quantized Filter) Si tiene variables con los mismos nombres en el área de trabajo y desea sobrescribirlas, active la casilla de verificación.Overwrite Variables

  5. Haga clic en el botón.Export Aparece el cuadro de diálogo Exportar a un archivo MAT.

  6. Elija o escriba un nombre de archivo y haga clic en el botón.Save

La exportación a un modeloSimulink

Si tiene el producto instalado, puede exportar un bloque del diseño del filtro e insertarlo en un modelo nuevo o existente.Simulink®SimulinkSimulink

Puede exportar un filtro diseñado con cualquier método de diseño de filtro disponible en.Diseñador de filtros

Nota

Si tiene el e instalado, puede exportar un filtro CIC a un modelo.DSP System ToolboxFixed-Point Designer™Simulink

  1. Después de diseñar el filtro, haga clic en el botón de la barra lateral o seleccioneRealize Model File > Export to Simulink Model. Se muestra el panel realizar modelo.

  2. Especifique el nombre que se usará para el bloque en.Block name

  3. Para insertar el bloque en el modelo actual (más recientemente seleccionado), establezca elSimulinkDestination Current. Para insertar el bloque en un nuevo modelo, seleccione New. Para insertar el bloque en un subsistema definido por el usuario, seleccione User defined.

  4. Si desea sobrescribir un bloque creado previamente desde este panel, compruebe.Overwrite generated `Filter' block

  5. Si selecciona la casilla de verificación, el filtro se crea como un bloque, que utiliza subelementos independientes.Build model using basic elementsSubsistema (Simulink) En este modo, están disponibles las siguientes optimizaciones:

    • Optimize for zero gains : Permite eliminar trazados de ganancia de valor cero de la estructura del filtro.

    • Optimize for unity gains — Sustituye un alambre (cortocircuito) por ganancias iguales a 1 en la estructura del filtro.

    • Optimize for negative gains — Sustituye un alambre (cortocircuito) por ganancias iguales a-1 y cambia las adiciones correspondientes a las sustracciones en la estructura del filtro.

    • Optimize delay chains — Cadenas de retardo sustitutivas compuestas por retrasos unitarios con un solo retardo.nn

    • Optimize for unity scale values : Permite eliminar las multiplicaciones de los valores de escala iguales a 1 de la estructura del filtro.

    En la siguiente ilustración se muestran los efectos de algunas de las optimizaciones:

    Nota

    La casilla de verificación está habilitada solo cuando tiene una licencia y el filtro se puede diseñar mediante un bloque o un bloque.Build model using basic elementsDSP System ToolboxBiquad FilterDiscrete FIR Filter Para obtener más información, consulte el tema en la documentación.Filter Realization WizardDSP System Toolbox

  6. Establezca el parámetro para especificar si el filtro generado realiza el procesamiento basado en muestras o fotogramas en la entrada.Input processing Dependiendo del tipo de filtro que diseñe, puede haber una o las dos opciones siguientes disponibles:

    • Columns as channels (frame based) : Al seleccionar esta opción, el bloque trata cada columna de la entrada como un canal independiente.

    • Elements as channels (sample based) : Cuando se selecciona esta opción, el bloque trata cada elemento de la entrada como un canal independiente.

  7. Haga clic en el botón para crear el bloque de filtro.Realize Model Cuando se selecciona la casilla de verificación, implementa el filtro como un bloque de subsistema utilizando, y bloques.Build model using basic elementsDiseñador de filtrosSumGainRetraso

Si haces doble clic en el bloque filtro, se muestra la estructura del filtro.Simulink

Generar un archivo de encabezado C

Es posible que desee incluir información de filtro en un programa de C externo. Para crear un archivo de encabezado C con variables que contengan datos de parámetros de filtro, siga este procedimiento:

  1. Seleccione Targets > Generate C Header. Aparece el cuadro de diálogo generar encabezado C.

  2. Introduzca los nombres de las variables que se utilizarán en el archivo de cabecera C. La estructura de filtro determinada determina las variables que se crean en el archivo.

    Estructura de filtro

    Parámetro variable

    Forma directa I

    Forma directa II

    Forma directa I transpuesto

    Forma directa II transpuesta

    , , ,NumeratorNumerator lengthDenominatorDenominator length

    Lattice ARMA

    , , ,Lattice coeff.Lattice coeff. lengthLadder coeff.Ladder coeff. length

    Lattice MA

    , y (inactivo si el filtro solo tiene una sección)Lattice coeff.Lattice coeff. lengthNumber of sections

    Abeto directo de forma directa FIR transpuesto

    , y (inactivo si el filtro solo tiene una sección)NumeratorNumerator lengthNumber of sections

    Las variables de longitud contienen el número total de coeficientes de ese tipo.

    Nota

    Los nombres de variable no pueden ser palabras reservadas del lenguaje C, como "for."

  3. Seleccione para utilizar el tipo de datos sugerido o seleccione y seleccione el tipo de datos deseado en el desplegable.Export SuggestedExport As

    Nota

    Si no dispone de software instalado, al seleccionar cualquier tipo de datos que no sea de punto flotante de precisión doble, se produce un filtro que no coincide exactamente con el que diseñó en el.DSP System ToolboxDiseñador de filtros Esto se debe a las diferencias de redondeo y truncamiento.

  4. Haga clic para guardar el archivo y deje el cuadro de diálogo abierto para las definiciones de archivo de encabezado C adicionales.Generate Para cerrar el cuadro de diálogo, haga clic en.Close

Generar códigoMATLAB

Puede generar código que construye el filtro que diseñó desde la línea de comandos.MATLABDiseñador de filtros Seleccione File > Generate MATLAB Code > Filter Design Function y especifique el nombre de archivo en el cuadro de diálogo generar código.MATLAB

Nota

No se puede generar código (MATLABFile > Generate MATLAB Code > Filter Design Function) si el filtro se diseñó o editó con el editor de polos/cero.

El siguiente es el código generado para el filtro paso bajo predeterminado en.MATLABDiseñador de filtros

function Hd = ExFilter %EXFILTER Returns a discrete-time filter object.  % % MATLAB Code % Generated by MATLAB(R) 7.11 and the Signal Processing Toolbox 6.14. % % Generated on: 17-Feb-2010 14:15:37 %  % Equiripple Lowpass filter designed using the FIRPM function.  % All frequency values are in Hz. Fs = 48000;  % Sampling Frequency  Fpass = 9600;            % Passband Frequency Fstop = 12000;           % Stopband Frequency Dpass = 0.057501127785;  % Passband Ripple Dstop = 0.0001;          % Stopband Attenuation dens  = 20;              % Density Factor  % Calculate the order from the parameters using FIRPMORD. [N, Fo, Ao, W] = firpmord([Fpass, Fstop]/(Fs/2), [1 0], [Dpass, Dstop]);  % Calculate the coefficients using the FIRPM function. b  = firpm(N, Fo, Ao, W, {dens}); Hd = dfilt.dffir(b);  % [EOF] 

Administración de filtros en la sesión actual

Puede almacenar filtros diseñados en la sesión actual para la cascada juntos, exportar a FVTool o para recordar más adelante en la misma o futuras sesiones.Diseñador de filtrosDiseñador de filtros

Puede almacenar y acceder a los filtros guardados con los botones y, respectivamente, en el panel.Store FilterFilter ManagerCurrent Filter Information

: Muestra el cuadro de diálogo filtro de tienda en el que se especifica el nombre de filtro que se utilizará al almacenar el filtro en el administrador de filtros.Store Filter El nombre predeterminado es el tipo del filtro.

: Abre el administrador de filtros.Filter Manager

El filtro actual se muestra debajo del cuadro de lista. Para cambiar el filtro actual, resalte el filtro deseado. Si selecciona, muestra las especificaciones de filtro seleccionadas actualmente.Edit current filterDiseñador de filtros Si realiza algún cambio en las especificaciones, el filtro almacenado se actualizará inmediatamente.

Para poner en cascada dos o más filtros, resalte los filtros deseados y pulse.Cascade Se agregará un nuevo filtro en cascada al administrador de filtros.

Para cambiar el nombre de un filtro almacenado, pulse.Rename Aparece el cuadro de diálogo Cambiar nombre del filtro.

Para eliminar un filtro almacenado del administrador de filtros, pulse.Delete

Para exportar uno o más filtros a FVTool, resalte el filtro (s) y pulse.FVTool

Guardar y abrir sesiones de diseño de filtro

Puede guardar la sesión de diseño de filtro como un archivo MAT y volver a la misma sesión en otro momento.

Seleccione el botón para guardar la sesión como un archivo MAT.Save Session La primera vez que guarde una sesión, se abrirá el explorador guardar sesión de diseño de filtro, solicitándole un nombre de sesión.

La extensión se agrega automáticamente a todas las sesiones de diseño de filtro que guarde..fda

Nota

También puede utilizar File > Save Session Y File > Save Session As para guardar una sesión.

Puede cargar las sesiones existentes seleccionando el botón oDiseñador de filtrosOpen Session File > Open Session . Se abre un explorador de sesión de diseño de filtro de carga que le permite seleccionar de las sesiones de diseño de filtro guardadas anteriormente.