Incorrect number of input arguments

6 views (last 30 days)
Hidd_1
Hidd_1 on 25 Jan 2022
Commented: _ on 25 Jan 2022
I wrote the following code, and I got a message error regarding the input arguments:
lgd_1 = legend(app.UIAxes,'dTdhw(°C)','VDHW(L/min)','SP_VDHW(L/min)','Location','northoutside','Interpreter','none','Orientation','horizontal');
title(app.UIAxes,lgd_1,'string(app.Appliance_Model_1) + " Buit by: " + string(app.Appliance_Manufacturer_1), "Test info: " + string(app.Test_info_1)','Interpreter','none')
I got the following error message and I don't know why?!
Incorrect number of input arguments

Accepted Answer

_
_ on 25 Jan 2022
It doesn't make sense to pass your legend to the title() function. You can remove it:
lgd_1 = legend(app.UIAxes,'dTdhw(°C)','VDHW(L/min)','SP_VDHW(L/min)','Location','northoutside','Interpreter','none','Orientation','horizontal');
title(app.UIAxes,'string(app.Appliance_Model_1) + " Buit by: " + string(app.Appliance_Manufacturer_1), "Test info: " + string(app.Test_info_1)','Interpreter','none')
  4 Comments

Sign in to comment.

More Answers (1)

Benjamin Thompson
Benjamin Thompson on 25 Jan 2022
Might need to see more code, or simplify your example down to one that does not depend on "app".
Initial guess is that the title function can only accept an axis object or legend object as the first argument, so you cannot pass both of them as the first two arguments. Since you passed axes to legend in the first line, trying to use legend again may be unnecessary, as the legend would have been put in your axis object already.

Products


Release

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by