MATLAB Answers

error message "install_unix: not found"

150 views (last 30 days)
HyunChul Youn
HyunChul Youn on 8 Feb 2015
Commented: Kurt Stewart alrededor de 19 horas ago
ubuntu 14.04, matlab 2014b
I am having troble installing matlab I aleady had solved my first installing problem "permission denied" (by using command "chmod -x") second, when I entered command "./install"
"./install: 1: eval: /home/mycom/batang/matlab/R2014b/bin/glnx86/install_unix: not found"
....
I do not understand this message. What should I do in order to complete the installation?
  4 Comments
Weiying Qiu
Weiying Qiu on 3 Jun 2016
Same issue. Cannot find install_unix on Linuxmint.

Sign in to comment.

Answers (4)

Randy A Lemons
Randy A Lemons on 25 Jul 2017
Edited: Randy A Lemons on 25 Jul 2017
Should anyone have this issue in the future, for me it was caused by using the wrong extraction method on the .zip file. I have 7zip installed on my 64bit machine and using the command:
7z e matlab_R2017a_glnxa64.zip
caused the file to extract but apparently not in the right way. The MATLAB directions at https://www.mathworks.com/help/install/ug/install-mathworks-software.html specifically call for you to use:
unzip matlab_R2017a_glnxa64.zip
which then allows the install to continue properly.
  3 Comments
David Alejandro Celaya González
it worked, the error was caused for the wrong extraction. Tks.

Sign in to comment.


Walter Roberson
Walter Roberson on 3 Jun 2016
You are trying to install onto a 32 bit Linux system. 32 bit Linux has not been supported for the last several releases.

Sean Ma
Sean Ma on 31 Jan 2018
Edited: Sean Ma on 31 Jan 2018
So I've encountered the same issue with you all for installing Matlab on CentOS 6 server. I made sure that I'm on `root` (with `sudo -i`) as well as all the folders/file have `write` access (with `chmod +x`) but I'm still getting all these errors.
After further investigation, Matlab's `install` script seems to make a copy of the essential installation files to `/tmp` and initiate the installation from there. Now someone mentioned in another forum ( https://www.centos.org/forums/viewtopic.php?t=22300 ) that possibly the `/tmp` folder which Matlab is installing has a `noexec` option when mounted where it doesn't let you execute any binary for security concerns.
You can check it with the `mount` command and it should display something like below with the `noexec` option at the `/tmp` line.
/dev/mapper/lv_tmp on /tmp type ext4 (rw,noexec)
To overcome that, you can temporarily disable it by
mount -o remount,exec /tmp
and retry your install. But be sure to enable it back later:
mount -o remount,noexec /tmp
Hope it helps you as well!

Markos Loizou
Markos Loizou on 23 Mar 2017
I had the same problem, and my system is 64 bits, you have to use sudo ./install since some of the folders and files the installation process is trying to access and modify need root privileges.
You can check your system version by uname -a or uname -i, if you get i386 then its 32 bits if x86_64 then it's a 64 bit. I hope this helps

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by