MATLAB Answers

Internal cam is not working in 2015 mtalba.

27 views (last 30 days)
Wajahat Nawaz
Wajahat Nawaz on 25 Oct 2015
Commented: Image Analyst on 27 Oct 2015
obj = videoinput('winvideo', 1)
Error using videoinput (line 217)
Invalid ADAPTORNAME specified. Type 'imaqhwinfo' for a list of available ADAPTORNAMEs. Image acquisition adaptors may be available as downloadable support packages.
Open Support Package Installer to install additional vendors.

Answers (3)

Image Analyst
Image Analyst on 25 Oct 2015
Show me a screenshot of the imaqtool interface. I need to see what video adapters you have present.
>>imaqtool
Use the green and brown frame icon to attach your image. You may find the http://snag.gy web site useful. You can do alt-PrintScreen to copy your active window to the clipboard, then paste it into snag.gy and paste the URL snag.gy gives you back here so we can see the image.
  1 Comment
Image Analyst
Image Analyst on 27 Oct 2015
Try this:
>> supportPackageInstaller
Tell it to Install from Internet. Then from the drop down list, click Show Installed. It should look like this:
Note the packages listed in the left hand panel. Post your screenshot.
If those are there, then post an image of Device Manager (if you have Windows) with the Imaging Devices category expanded.

Sign in to comment.


Walter Roberson
Walter Roberson on 26 Oct 2015
Did you open the Support Package Installer and install the camera package?

Madhura Suresh
Madhura Suresh on 27 Oct 2015
What support package did you install? What camera/framegrabber do you have?

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by