Imaq functions dont work when compiled on 32bit system

3 views (last 30 days)
Valentino Tomasic
Valentino Tomasic on 7 Dec 2015
Commented: Valentino Tomasic on 11 Dec 2015
I made an application using imaq toolbox. Then I compiled it for 64bit and 32bit systems and tested it. The application worked good for the 64bit system. Whereas on the 32bit system I got an error saying and imaq function can not be found. Here's some code, where I try to find the right camera and open the camera:
deviceID = [];
imaqreset;
info = imaqhwinfo('winvideo');
devnumb = numel(info.DeviceIDs); %get number of available devices
for i=1:devnumb
if ~isempty(strfind(info.DeviceInfo(i).DeviceName,'UI224xSE-M')) %%find my camera
deviceID = info.DeviceInfo(i).DeviceID;
end
end
if ~isempty(deviceID)
vidH = videoinput('winvideo', deviceID, 'RGB32_1280x1024'); %create video object
.... %continue with initialization of video object
end
When I try to run the .exe file I get 'Undefined function or variable 'imaqreset'.'
I can also assure, that I have installed the imaq toolbox, because it works on 64bit but also by typing
>>ver
MATLAB Version 8.3 (R2014a)
Image Acquisition Toolbox Version 4.7 (R2014a)
Image Processing Toolbox Version 9.0 (R2014a)
MATLAB Builder JA Version 2.3.1 (R2014a)
MATLAB Compiler Version 5.1 (R2014a)
Next I tried to comment out the line with imaqreset, because it is not really necessary but the i got the same error saying there is no defined function imaqhwinfo.
So why does my application work on 64bit systems but not on 32bit?
  2 Comments
Valentino Tomasic
Valentino Tomasic on 11 Dec 2015
Yes I used the same .m file for both 32bit and 64bit. And yes, it works correctly when I run it in 32bit Matlab.

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by