MATLAB Answers

copy from UITABLE to clipboard not working

51 views (last 30 days)
I have a UI table, I used to be able to copy from it to the windows clipboard, but now it no longer copies. I have absolutely no idea what has changed nor where to look for the problem. Any thoughts on where the problem might be?
thanks Greg


Sign in to comment.

Accepted Answer

Gregory McFadden
Gregory McFadden on 25 Apr 2017
it actually was some kind of "as currently running" issue. Restarting matlab fixed the issue.


Sign in to comment.

More Answers (2)

xi on 25 Apr 2017
You may want to change the uitable property of 'ColumnEditable' from true to false. When it is true, you can edit, but can't copy the whole table to clipboard (can only copy one cell at a time). When it is false, you can't edit, but can copy the talbe. I usually add a toggle button beside the uitable, so that users can switch between copy mode and edit mode. I'm not sure if this is the problem you encountered.

  1 Comment

Sign in to comment.

Feng on 10 Oct 2019
i also have this problem with 2019b. has anyone found a solution?


Show 1 older comment
Feng on 11 Oct 2019
This is frustrating. I have tried many different ways but still can't get around this issue...
Feng on 14 Oct 2019
Matlab has confirmed the function is missing for uitable and hopefully this will be addressed in the next release. in the meantime, use clipboard for it but i won't copy the format of the table.
Luna on 16 Oct 2019
I think writing our own copy to clipboard function and calling it in cellSelectionCallback will solve. But I haven't tried yet. I will give a feedback asap.

Sign in to comment.



Translated by