MATLAB Answers


S-Function MAX6675 for Arduino MEGA2560

Asked by Tobias Winzel on 3 Jan 2018
Latest activity Commented on by Sofia Ricalde Sanchez on 16 Apr 2019
Hello everyone,
since Christmas I'm desperately trying to create my own s-function block for a MAX6675 (I want to mease some temperatures). I have seen several Videos how to do it, the s-Function itself is successfully created but if I want to start my Model on my Arduino I'm always getting the same Error and I can't figure out why -.-
That's why I'm desperately looking for some help...
Thank you for your help :)
with best regards


Sign in to comment.

3 Answers

Answer by Nick Sarnie on 5 Jan 2018

Hi Tobi,
Based on the compiler errors and looking at the model, it looks like the custom code included in S-Function Builder is C++. S-Function Builder only supports the C language. I recommend modifying the custom code to work in C.

  1 Comment

Hey Nick,
thank you for your answer, I solved this Issue, but the next thing which appears that Simulink can't handle is the following line from my attached file:
"unrecognized mmcu atmega2560".... I I don't know what this means or how I can solve this new issue I'm having right now...
I've also attached my new SimulinkModel which belongs to the Error-file.
Do you or somebody else have some solution for me?
thank you for your help!!!!

Sign in to comment.

Answer by Tobias Wzl on 19 Jan 2018

I solved the whole problem!!! The pins from the IDE-Code have to be declared as parameters in the s-function block
the loop function has to be put in the OUTPUT-Writer and thats it


Hi Tobias,
I'm new in arduino and in need of reading some temperature data from MAX6675 from matlab. Can you please share with me how you created the matlab function. thanks in advance..!!

Sign in to comment.

Answer by wael ahmed on 29 Sep 2018

Hi Tobias,
I have built the MAX6675 sFunction and it has no errors, I am working on getting data on external mode but it gives only a constant value on the scope despite the sensor being heated. Any idea what could be the problem?


Sign in to comment.