MATLAB Answers

Problem when save plots

3 views (last 30 days)
Gustavo
Gustavo on 8 May 2012
Hi,
I have a plot that is constituted by 3 plots together (using subplot). Each graph is composed of several lines, in the positive and negative range (between y=-1 and y=1), but all of them have some region that y=0 (at the same time).
In this y=0 region, instead of having a plot of one thin line, my line is sometimes thick, as if i have used plot(a,b,'k','linewidth',2), but i have not done it.
When you zoom in the effect disappear. If you change the size of the window, it can vanish or appear in other region.
My real problem is that it keep there when export to EPS, specially if i try to make it smaller.
Any hints??

  0 Comments

Sign in to comment.

Answers (2)

Jessica Lam
Jessica Lam on 9 May 2012
if it is possible, you may change the resolution of your image. Eg. Resolution: 470 X 274
set(gcf,'PaperUnits','inches','PaperPosition',[0 0 4.7 2.74])
print('-depsc', 'filename.eps', '-r100')

  1 Comment

Gustavo
Gustavo on 9 May 2012
Hej, Thanks for the tip, but it doesn't work either.
I need the ouput in a specific size, so i use:
THSize = [ 20.0 12.5 (20.0/12.5) ];
A4Size = [297,210,(297/210)];
fig33 = figure( 'PaperOrientation', 'portrait', ...
'PaperType','a4','PaperUnits','points', ...
'Position', [ 0 0 1.0*A4Size(2) 1.0*A4Size(1) ]*5.2/2.54, ...
'PaperPosition',[ 0 0 1.0*THSize(2) 1.0*THSize(1) ]*72/2.54)
I tried to change the resolution on the printer ('-rXXX'), and the problem remains.

Sign in to comment.


Walter Roberson
Walter Roberson on 9 May 2012
Experiment with changing your renderer.
And consider using the File Exchange contribution export_fig()

  0 Comments

Sign in to comment.

Sign in to answer this question.

Products


Translated by