MATLAB Answers

Failed to load device plug-in

32 views (last 30 days)
I'm using the data acquisition toolbox and NI hardware to acquire data into MATLAB. I have installed all the latest drivers, toolbox and matlab versions and all my hardware devices are supported except for the cDAQ-9185 chassis. I have no problem creating sessions but I get the plug-in error when I try to add analog input channels. I don't think that the cDAQ-9185 Chassis is the problem because I can add analog output channels and occasionally I'm able to add analog input channels. I don't know what the problem is so any help is much appreciated.
Error: Failed to load device plug-in: 'mwnidaqmxai'. Check that the DAQ Toolbox and NIDAmx drivers are installed properly.
Thanks
  3 Comments
Akihiko Watanabe
Akihiko Watanabe on 12 Aug 2018
I have the same issue. I am using "NI USB-6009" ONLY. The Data Acquisition Tool supports this device. And the version of NI-DAQmx is 18.0.
I have tried an following example of Mathworks Website.
openExample('daq/demo_compactdaq_intro')
But following error occurs when "addAnalogInputChannel" function is executed.
Failed to load device plug-in: 'mwnidaqmxai'. Check that the DAQ Toolbox and NIDAQmx drivers are installed properly.
I am still suffering this issue.

Sign in to comment.

Accepted Answer

Nirav Sharda
Nirav Sharda on 2 Jul 2018
Edited: Nirav Sharda on 2 Jul 2018
R2018a version of MATLAB requires NI-DAQmx 17.1 and you are using a different version. So, use the 17.1.0 version of NI-DAQmx which is supported by MATLAB R2018a by following the below instructions:
1. Uninstall existing NI-DAQmx version
2. Download and install NI-DAQmx 17.1.0
3. Reboot computer
  4 Comments
Abdul Rahman Samewoi
Abdul Rahman Samewoi on 19 Sep 2019
Hi, what if only analog input or digital input has the problem above? analog output and digital output are okay. I am using R2018a version of MATLAB and NI-DAQmx 17.1. Please advice me.

Sign in to comment.

More Answers (7)

Andrei Ursache
Andrei Ursache on 30 Aug 2018
Edited: Andrei Ursache on 30 Jan 2019
To resolve this issue you can upgrade/update to R2018b Update 1.
Please refer to the following bug report for a possible temporary workaround in R2018a. You can also opt in to receive automatic notifications when a fix is available for R2018a.
  1 Comment
Thomas Richner
Thomas Richner on 30 Aug 2018
Yes, please take a look at this bug report. They accurately describe the problem, at least in my case.

Sign in to comment.


Thomas Richner
Thomas Richner on 30 Jul 2018
I get this error when I try to que too large a vector (~ few GB) to the analog out. If I decrease the size of the vector it works fine. So it seems the error code is largely unrelated to the actual cause.

Pirmin Boch
Pirmin Boch on 15 Aug 2018
I have the same problem. Also after I uninstalled NI_DAQmx version 18 and installed NI_DAQmx version 17.1.
I use a NI PXIe 6363 and a NI PXIe 6238 and Matlab 2018a.
Does somebody have a solution for this problem?

Akihiko Watanabe
Akihiko Watanabe on 15 Aug 2018
I found a countermeasure to reduce the occurrence frequency of this issue (NOT a perfect countermeasure). Even after this countermeasure sometimes the same issue occurs, but the occurrence frequency of this issue is very low on my PC.
This countermeasure is for Microsoft Windows only. Refer to following image also.
1. Launch the "System Configuration"
2. Click the Services tab.
3. Sort by manufacturer (Blue Box in the image).
4. Find the service of National Instruments.
5. Originally, the all services of National Instrument are turned on. Turn OFF these services except Red box in the image.
6. Click the OK button on the system configuration.
7. Reboot the OS.
<Image of "System Configuration (Japanese Version) >
  1 Comment
Pirmin Boch
Pirmin Boch on 15 Aug 2018
These countermeasures unfortunately do not have any positive effect on my system.

Sign in to comment.


Chaitanya Jha
Chaitanya Jha on 22 Aug 2018
I am facing the same issue on Windows 10 while using NI USB-6221oem. This device is supported by Matlab. The problem arises when I am trying to add an Input or Output channel. It used to happen once or twice in a day, all other times it used to work perfectly in the last 2 months that I have used this NI device. Recently, in the last couple of days, it started to happen more frequently, but I was able to get rid of this issue by restarting my computer. However, from today, even the restarting the Windows doesn't help.
  3 Comments
Andrei Ursache
Andrei Ursache on 30 Aug 2018
Thank you Chaitanya!

Sign in to comment.


Abdul Rahman Samewoi
Abdul Rahman Samewoi on 4 Jan 2019
Have anyone solved this problem? I am facing the same problem using USB 6211 NI-DAQmx version 18.1 , Matlab 2018a and window 10.
I could load analog output and digital output channels but problem to load analog input channels that give : failed to load device plug-in: 'mwnidaqmxai'. check that the daq toolbox and nidaqmx drivers are installed properly.
  3 Comments
Aleksandr Sidun
Aleksandr Sidun on 23 May 2019
See my suggestions below

Sign in to comment.


Aleksandr Sidun
Aleksandr Sidun on 23 May 2019
You can try to write commands 'clear all','close all' to free up your RAM. It works in my case.
Also, you can try to reduce the sample size/sampling frequency to reduce the amount of data.

Products


Release

R2018a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by