MATLAB Answers

Multiple Webcam Acquisition error

2 views (last 30 days)
Tiago
Tiago on 14 Feb 2013
Commented: Tiago on 14 Dec 2015
I'm having this problem with the Image Acquisition ToolBox.
I'm trying to capture images from two USB webcams. When I try to preview each webcam separately, there is no problem. But when I try to preview both webcams at the same time I get this error on the second preview:
Error using imaqdevice/preview (line 177)
The image acquisition device failed to start acquiring images.
Any idea? I tried to connect my webcams in different USB ports and even whith a PCI USB expansion card and always the same problem.
This is my code (it only previews vid1):
vid1 = videoinput('linuxvideo',1);
vid2 = videoinput('linuxvideo',2);
subplot(211)
h1 = image;
preview(vid1,h1)
subplot(212)
h2 = image;
preview(vid2,h2)
  1 Comment
Tiago
Tiago on 20 Feb 2013
It looks like that my USB bandwidth is full and even lowering the frame rate to the minimum possible doesn't solve.

Sign in to comment.

Answers (1)

JULIO LOPEZ CASTILLEJOS
JULIO LOPEZ CASTILLEJOS on 11 Dec 2015
Hi,
I already made a code that made 4 cameras work at the same time, my problem is that when I close the preview windows and try to made the code to work again this error apears and dosen't let me get images, did you fix your problem and/or have an idea of how to fix it?
Thank you for advance and hope you or anyone can help me.
  1 Comment
Tiago
Tiago on 14 Dec 2015
As I said, my problem was due to USB bandwidth. Adding a new PCI USB expansion to you computer should solve your problem.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by