Trouble with Matlab Engine

11 views (last 30 days)
Bledian Nela
Bledian Nela on 14 Nov 2020
Commented: Bledian Nela on 19 Nov 2020
Hello Matlab Team,
I tried to install the matlab.engine on Ubuntu-Linux based on the steps shown in this link:
and I am still getting the following error:
EnvironmentError: Please reinstall MATLAB Engine for Python or contact MathWorks Technical Support for assistance: /usr/local/MATLAB/R2019b/extern/engines/python/dist/matlab/engine/glnxa64/../../../../../../../bin/glnxa64/libssl.so.1.1: undefined symbol: EVP_idea_cbc, version OPENSSL_1_1_0
I am using MATLAB version R2019b with an academic licence from Sapieza University and Python 3.7.6.
Thank you in advance!

Answers (1)

Deepak Meena
Deepak Meena on 17 Nov 2020
Hi Bledian,
If you are able to install the MATLAB engine and you getting the error while calling the MATLAB engine in python then this issue occurs when there is a conflict with the version of the "libssl.so" shipped with MATLAB and the one in the system. In order to fix this, load the SSL libraries first:
>>> import ssl
>>> import matlab.engine
>>> eng = matlab.engine.start_matlab()
If you are getting the error while installing the matlab engine , let us know at which step you are getting the error.
Thanks
Deepak
  1 Comment
Bledian Nela
Bledian Nela on 19 Nov 2020
Thank you very much for you help.
I modified something in my code and installation which works perfect now.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by