Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Analizar dependencias del proyecto

Para analizar la estructura de un proyecto y detectar los archivos requeridos por el proyecto, ejecute un archivo.Análisis de dependencia Puede ejecutar el análisis de dependencias en cualquier momento del flujo de trabajo cuando desee comprobar que el proyecto tiene todos los archivos necesarios. Por ejemplo, es una buena idea comprobar las dependencias al configurar un proyecto, antes de enviar una versión del proyecto al control de código fuente y antes de compartir el proyecto.

La ejecución de un análisis de dependencia puede mostrarle cómo un cambio afecta a otros archivos antes de realizar el cambio. Por ejemplo, es habitual usar el análisis de dependencias para examinar la estructura del proyecto, buscar, investigar y resolver problemas en archivos de proyecto, o para buscar las cajas de herramientas requeridas por el proyecto. Al investigar el impacto potencial de un cambio en los requisitos, utilice el análisis de dependencias para buscar los archivos de diseño vinculados al documento de requisitos. También puede utilizarlo para investigar el impacto del conjunto de cambios encontrando dependencias de los archivos modificados en sentido ascendente y descendente antes de confirmar los cambios. Encontrar estas dependencias puede ayudarle a identificar el diseño y los archivos de prueba que necesitan modificaciones y ayudarle a encontrar las pruebas que necesita para ejecutar.

Después del análisis de dependencia, puede abrir o etiquetar los archivos. También puede exportar los resultados como variables de espacio de trabajo, imágenes o archivos que se pueden recargar. Y puede enviar estos archivos para el procesamiento de tareas personalizadas. La exportación de los resultados permite procesar o archivar los resultados del análisis de impacto. Puede Agregar la lista exportada de archivos a informes u otros documentos que describan el impacto de un cambio.

Ejecutar análisis de dependencia

Antes de ejecutar un análisis de dependencia en un proyecto, asegúrese de que ha agregado todos los archivos al proyecto. El análisis de dependencia solo comprueba los archivos del proyecto. Para obtener más información, consulte.Agregar archivos a Project

Para ejecutar un análisis de dependencia en todos los archivos del proyecto, seleccione la vista.Dependency Analysis A continuación, en la ficha, haga clic enDependency Analysis.Analyze

Para analizar solo archivos específicos, en la pestaña, haga clic enDependency Analysis Analyze > Select Files to Analyze. Seleccione los archivos para analizarlos y, a continuación, haga clic.Analyze

Para analizar las dependencias de las cajas de herramientas externas, en la ficha, haga clic enDependency Analysis Options > Analyze External Toolboxes.

Después de realizar el análisis de dependencias, los espectáculos:Impact View

  • La estructura del proyecto y sus dependencias de archivo, que muestra cómo los archivos como modelos, bibliotecas, funciones, archivos de datos, archivos de origen y archivos derivados se relacionan entre sí.

  • Productos y cajas de herramientas requeridos.

  • Relaciones entre los archivos de origen y los derivados (como archivos, y, y, o y archivos) y entre los archivos de encabezado y origen de C/C++..m.p.slx.slxp.ssc.sscp.c.mex Puede ver qué código genera cada modelo y encontrar qué código se debe regenerar si modifica un modelo.

  • Advertencias sobre archivos de problemas, como archivos que faltan, archivos que no están en el proyecto, archivos con cambios no guardados y archivos derivados desfasados.

Para examinar las dependencias del proyecto y los archivos de problemas, en la parte superior derecha de la vista, haga clic en.Dependency AnalysisTable View

Después de ejecutar el primer análisis de dependencia del proyecto, los análisis subsiguientes son actualizaciones incrementales. Sin embargo, si actualiza las cajas de herramientas externas y desea detectar los cambios de dependencia en ellas, debe realizar un análisis completo. Para realizar un análisis completo, vaya a la pestaña y haga clic enDependency Analysis Analyze > Reanalyze All.

Para obtener más información sobre cómo ejecutar un análisis de dependencia en modelos y bibliotecas, consulte.Simulink®Perform Impact Analysis (Simulink)

Investigar y resolver problemas

Después de ejecutar un análisis de dependencia, el gráfico de impacto para todo el proyecto aparece en.Impact View El análisis de dependencia del proyecto identifica los problemas, como los archivos que faltan, los archivos que no están en el proyecto, los cambios no guardados y los archivos derivados desfasados. Puede examinar los archivos de problemas mediante la o la.Impact ViewTable View

Utilice la para investigar gráficamente los archivos de problemas.Impact View El centro de la vista muestra el gráfico de impacto del proyecto. El panel derecho de la muestra las dependencias de Toolbox y una lista de archivos problemáticos.Impact View

  • Para mostrar solo los archivos de problemas en el gráfico, mantenga el puntero sobre el encabezado en el panel derecho del y haga clic en.ProblemsImpact ViewFind All Para volver a la vista de proyecto completa, borre el filtro en el cuadro de búsqueda (por ejemplo, Dependencies of "filename").

  • Para ver los detalles de un archivo de problemas específico, incluida la ruta de acceso, el tipo y el mensaje de problema, seleccione el archivo en el gráfico. Para borrar la selección de archivo y ver todos los archivos de problemas de un proyecto, haga clic en un área en blanco del gráfico.

  • Para ver las dependencias de un archivo, sitúe el cursor sobre el archivo de problemas y haga clic en.Find All El gráfico se actualiza para mostrar solo el archivo de problemas y sus dependencias. Para volver a la vista de proyecto completa, borre el filtro en el cuadro de búsqueda (por ejemplo,).problem=='*'

Utilice la para investigar las dependencias del proyecto y los archivos de problemas como una tabla.Table View Para usar la, en la parte superior derecha de la vista, seleccione.Table ViewDependency AnalysisTable View

  • Para ver los archivos con problemas en la parte superior de la lista, ordene la tabla por la columna.Problem Description

  • Para ver los problemas de un archivo, compruebe el mensaje en la columna de ese archivo.Problem Description

  • Para ver las dependencias de un archivo, seleccione el archivo en la tabla. En el panel inferior se muestran los archivos que dependen del archivo seleccionado. Puede ver el o cambiar a la.Directly Impacted FilesDirectly Required Files

Resolver problemas

Para cada archivo de problema, tome medidas para resolver el problema. Esta tabla enumera los problemas comunes y describe cómo corregirlos.

Mensaje de problema

Descripción

Arreglar

Not in project

El archivo no está en el proyecto.

Agregue el archivo al proyecto.

No es necesario agregar todos los archivos necesarios al proyecto. Por ejemplo, puede excluir los archivos binarios de función S derivados que genera el código fuente del proyecto. Para obtener más información, consulte.Agregar archivos a Project

Para eliminar un archivo de la lista de problemas sin agregarlo al proyecto, haga clic con el botón derecho en el archivo y selecciónelo.Add External File

Missing project file

El archivo está en el proyecto, pero no existe en el disco.

Cree el archivo o recuperarlo mediante el control de código fuente.

Outside project root

El archivo está fuera de la carpeta raíz del proyecto.

Si esto está bien, establezca el archivo como un archivo externo. De lo contrario, muévase bajo la raíz del proyecto.

Si necesita un archivo que está fuera de la raíz del proyecto para estar en el proyecto, copie o mueva el archivo dentro de la raíz del proyecto y agréguelo al proyecto y la ruta de acceso. Quite la ubicación del archivo original de la ruta.

Si los archivos requeridos están fuera de la raíz del proyecto, no puede agregar estos archivos al proyecto. Es posible que esta dependencia no indique un problema si el archivo está en la ruta de acceso y es una utilidad o un recurso que no forma parte del proyecto. Use el análisis de dependencia para asegurarse de que comprende las dependencias de diseño.

In unreferenced project

El archivo se encuentra dentro de un proyecto al que no hace referencia el proyecto actual.

Agregue el proyecto que contiene el archivo como referencia de proyecto.

Missing file

No se puede encontrar el archivo o la variable.

Si este estado es aceptable, haga clic con el botón derecho en el archivo y selecciónelo.Add External File

Unsaved changes

El archivo tiene cambios sin guardar en el editor.MATLAB®

Guarde el archivo.

Derived file out of date

El archivo derivado es más antiguo que el archivo de origen del que se derivó.

Regenerar el archivo derivado. Si es un archivo, puede regenerarlo automáticamente ejecutando las comprobaciones del proyecto..p En la pestaña, haga clic y siga las instrucciones para reconstruir los archivos.ProjectCheck Project

Si cambia el nombre de un archivo de origen, el proyecto detecta el impacto en el archivo derivado y le pide que lo actualice.

Missing product

El proyecto tiene una dependencia de un producto que falta.

Instale el producto que falta.

Buscar cajas de herramientas requeridas

Después de ejecutar un análisis de dependencia en un proyecto, el muestra las cajas de herramientas necesarias para todo el proyecto o para los archivos seleccionados.Impact View Puede ver qué productos son necesarios para usar el proyecto o encontrar qué archivo está introduciendo una dependencia de producto.

En el panel derecho de la vista, la sección muestra los productos necesarios para todo el proyecto.Dependency AnalysisProduct Para ver los productos requeridos por los archivos seleccionados, seleccione algunos archivos haciendo clic en el gráfico o en una leyenda.

Para encontrar qué archivo está introduciendo una dependencia de producto, sitúe el cursor sobre el nombre del producto y haga clic en.Find Usages

El gráfico se actualiza para mostrar solo los archivos que utilizan el producto seleccionado. Para volver a la vista de proyecto completa, borre el filtro en el cuadro de búsqueda (por ejemplo, Usages of "productname").

Si falta un producto necesario, la lista de productos lo etiqueta.Missing Para resolver un producto que falta, instale el producto y vuelva a ejecutar el análisis de dependencia.

Encontrar dependencias de archivos

Para investigar las dependencias de un archivo después de ejecutar un análisis de dependencia, haga clic con el botón derecho en el archivo del gráfico y seleccione, o.Impact ViewFind All DependenciesFind Impacted FilesFind Required Files El gráfico muestra el archivo seleccionado y las dependencias del archivo.

Como alternativa, seleccione el archivo, vaya a la pestaña y, en la sección, haga clic en.Dependency AnalysisImpact AnalysisFind Seleccione entre las opciones disponibles.

Para seleccionar grupos de archivos, en la leyenda en la esquina superior izquierda de la, seleccione entre las opciones disponibles.File TypeImpact View Por ejemplo, para seleccionar todos los archivos de función, haga clic y seleccione.File TypeFunction Para cambiar la forma en que se agrupan los archivos de la vista, vaya a la pestaña y, en la sección, haga clic en.Dependency AnalysisViewGroup By Seleccione entre las opciones disponibles.

Para seleccionar archivos modificados, archivos de problemas o archivos externos, vaya a la pestaña y, en la sección, haga clic en.Dependency AnalysisImpact AnalysisSelect Seleccione entre las opciones disponibles.

Para examinar o editar una dependencia de archivo, expanda el archivo haciendo clic en las flechas junto al nombre del archivo en el gráfico. A continuación, haga doble clic en el componente de referencia (por ejemplo, una línea de código que hace referencia a un archivo de problemas) para abrirlo.MATLAB Para expandir todos los archivos del gráfico, en la sección, haga clic en.ViewExpand All

Para restablecer el gráfico y mostrar todas las dependencias analizadas en el proyecto, en la pestaña, en la sección, seleccioneDependency AnalysisImpact Analysis Find > All Files.

Sugerencia

Para proyectos grandes, la visualización de los resultados en una tabla puede facilitar la navegación. Para usar la, en la parte superior derecha de la vista, seleccione.Table ViewDependency AnalysisTable View

Buscar documentos de requisitos

En un proyecto, un análisis de dependencia encuentra los documentos de requisitos vinculados mediante la interfaz de administración de requisitos.

  • Puede ver y navegar hacia y desde los documentos de requisitos vinculados.

  • Solo puede crear o Editar vínculos de administración de requisitos si tiene SimulinkRequisitos™.

Para resaltar los documentos de requisitos en el gráfico, en la parte superior derecha de la, haga clic en la leyenda y seleccione.Impact ViewDependency TypeRequirements Link Las flechas conectan los documentos de requisitos a los archivos con los enlaces de requisito.

Para encontrar los enlaces de requisitos para un archivo específico, expanda el archivo haciendo clic en las flechas junto al nombre del archivo en el gráfico. Para expandir todos los archivos del gráfico, en la sección, haga clic en.ViewExpand All Una flecha conecta el componente que contiene el vínculo de requisito con el documento de requisitos.

Para abrir un documento de requisitos, haga doble clic en el documento en el gráfico.

Guardar, abrir y comparar resultados de análisis de dependencia

Después de ejecutar un análisis de dependencia en un proyecto, puede guardar los resultados del análisis. A continuación, puede abrir y ver los resultados sin tener que repetir el análisis.

Para guardar los resultados como un archivo, vaya a la pestaña y, en la sección, haga clic en..graphmlDependency AnalysisFileSave As Elija un nombre de archivo y una ubicación.

Para abrir un resultado de análisis de dependencia guardado, en la pestaña, en la sección, haga clic en.Dependency AnalysisFileOpen

Para comparar los resultados de un análisis de dependencia actual con los resultados guardados anteriormente, vaya a la pestaña y, en la sección, haga clic en.Dependency AnalysisFileCompare to Saved Seleccione un archivo e inspeccione las diferencias en el informe de comparación..graphml

Exportar archivos en vista de impacto

Para exportar todos los archivos mostrados en el análisis de dependencia, en primer lugar, haga clic en el fondo del gráfico para borrar la selección en todos los archivos.Impact View A continuación, vaya a la pestaña y, en la sección, haga clic en.Dependency AnalysisImpact AnalysisExport Seleccione una de las opciones disponibles:

  • : Permite guardar las rutas de archivo seleccionadas en una variable.Save to Workspace

  • : Abra el cuadro de diálogo tarea personalizada con los archivos seleccionados.Send to Custom Task

  • — Cambie a la vista con los archivos seleccionados.Show in Files ViewFiles

Para exportar un subconjunto de archivos en el gráfico, seleccione los archivos y, a continuación, haga clic en.Export El menú muestra cuántos archivos se seleccionan: Selected files: number of files . Alternativamente, puede hacer clic con el botón derecho en los archivos seleccionados y seleccionar entre las opciones del menú.Export

Exportar gráfico a archivo de imagen

Para exportar el gráfico como un archivo de imagen para compartir o archivar, vaya a la pestaña y, en la sección, seleccioneImpact ViewDependency AnalysisFile Save As > Save As Image. Utilice el cuadro de diálogo Guardar para especificar el nombre, el tipo de archivo y la ubicación. El tipo de archivo predeterminado es SVG, que admite el escalado de imágenes.

También puede copiar la imagen en el Portapapeles con el teclado. A continuación, puede pegar el contenido del portapapeles en otros documentos.

Temas relacionados