Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Ver secuencias de imágenes en la aplicación Visor de vídeo

En esta sección se describe cómo usar la aplicación Visor de vídeo para ver secuencias de imágenes y se proporciona información sobre cómo configurar la aplicación Visor de vídeo.

Ver la secuencia de RMN con la aplicación Visor de vídeo

En este ejemplo se muestra cómo ver datos volumétricos de varios sectores en la aplicación Visor de vídeo.

Cargue la secuencia de imágenes en el espacio de trabajo.MATLAB® En este ejemplo, cargue los datos de RMN desde el archivo, que se incluye en la carpeta.mristack.matimdata

load mristack

Esto coloca una variable con nombre en el área de trabajo.mristack La variable es una matriz de 21 marcos en escala de grises que contienen imágenes de RMN del cerebro. Cada fotograma es una matriz de datos de 256 por 256.uint8

mristack       256x256x21       1276256     uint8

Haga clic en la aplicación Visor de vídeo en la galería de aplicaciones y seleccione la opción en el menú Archivo.Import from workspace También puede llamar a , especificando el nombre de la variable de secuencia de imágenes como argumento.implay

implay(mristack)

Se abre el Visor de vídeo, que muestra el primer fotograma de la secuencia de imágenes. Observe cómo el Visor de vídeo muestra información sobre la secuencia de imágenes, como el tamaño de cada fotograma y el número total de fotogramas, en la parte inferior de la ventana.

Explore la secuencia de imágenes con los controles de reproducción del Visor de vídeo.

Para ver la secuencia de imágenes o el vídeo como una animación, haga clic en el botón Reproduciren la barra de herramientas Reproducción, seleccione en el menú Reproducción o pulse o la barra espaciadora.PlayP De forma predeterminada, el Visor de vídeo reproduce la secuencia de imágenes hacia delante, una vez en su totalidad, pero puede ver los fotogramas de la secuencia de imágenes de muchas maneras, que se describen en esta tabla. Al ver una secuencia de imágenes, observe cómo el Visor de vídeo actualiza la barra de estado en la parte inferior de la ventana.

Opción de visualizaciónControl de reproducciónMétodo abreviado de teclado
Especifique la dirección en la que desea reproducir la secuencia de imágenes.Haga clic en el botón Modo de reproducciónen la barra de herramientas Reproducción o seleccione en el menú Reproducción.Playback Modes Puede seleccionar Avance, Retroceso o Inversión automática. Al hacer clic en el botón de modo de reproducción, el Visor de vídeo recorre estas opciones y la apariencia cambia para indicar la selección actual. El Visor de vídeo utiliza signos más (+) y menos (-) para indicar la dirección de reproducción en la pantalla Fotograma actual. Cuando reproduce un vídeo al revés, los números de fotograma mostrados son negativos. Cuando se encuentra en modo de inversión automática, el Visor de vídeo utiliza signos más para indicar la dirección de avance.Un
Ver la secuencia repetidamente.Haga clic en el botón Repetiren la barra de herramientas Reproducción o seleccione en el menú Reproducción.Playback Modes > Repeat Esta opción se activa o desactiva.R
Vaya a un fotograma específico de la secuencia.Haga clic en el botón Saltar aen la barra de herramientas Reproducción o seleccione en el menú Reproducción.Jump to Esta opción abre un cuadro de diálogo en el que puede especificar el número del marco. J
Detenga la secuencia.Haga clic en el botón Deteneren la barra de herramientas Reproducción o seleccione en el menú Reproducción.Stop Este botón solo se activa cuando se reproduce una secuencia de imágenes.S
Recorre la secuencia, un fotograma a la vez o salta al principio o al final de la secuencia (rebobinar).Haga clic en uno de los botones de navegaciónen la barra de herramientas Reproducción, en la dirección deseada, o seleccione una opción, como o desde el menú Reproducción.Fast ForwardRewind

Teclas de flecha /Página arribaPágina abajo

(último fotograma) (primer fotograma)LF

Cambie la vista de la secuencia de imágenes o examine un fotograma más de cerca.

El Visor de vídeo admite varias herramientas enumeradas en el menú Herramientas y en la barra de herramientas que puede utilizar para examinar los fotogramas de la secuencia de imágenes más de cerca.

Opción de visualizaciónControl de reproducción
Acercar o alejar la imagen y desplazarla para cambiar la vista. Haga clic en uno de los botones de zoomen la barra de herramientas o seleccione o en el menú Herramientas.Zoom InZoom Out Haga clic en el botón Panorámicaen la barra de herramientas o seleccione en el menú Herramientas.Pan Si hace clic en Mantener ajuste al botón de la ventanaen la barra de herramientas o seleccione o, en el menú Herramientas, los botones de zoom y panorámica están desactivados.Maintain fit to window
Examine un área del marco actual en detalle. Haz clic en el botón Región de píxelesen la barra de herramientas Reproducción o seleccione en el menú Herramientas.Pixel Region
Exportar fotograma al Visor de imágenesHaga clic en el botón Exportar a herramienta de imagenen la barra de herramientas Reproducción o seleccione en el menú Archivo.Export to Image Tool La aplicación Visor de vídeo abre un Visor de imágenes que contiene el fotograma actual.

Configurar la aplicación Visor de vídeo

El cuadro de diálogo Configuración de la aplicación Visor de vídeo le permite cambiar la apariencia y el comportamiento del reproductor. Para abrir el cuadro de diálogo Configuración, seleccione File > Configuration > Edit. (Para cargar un conjunto de configuración preexistente, seleccione File > Configuration > Load.)

El cuadro de diálogo Configuración contiene cuatro fichas: Núcleo, Orígenes, Visuales y Herramientas. En cada ficha, seleccione una categoría y, a continuación, haga clic en Propiedades para ver los valores de configuración.

En la tabla siguiente se enumeran las opciones que están disponibles para cada categoría en cada panel.

PanelCategoría de opciónDescripciones de opciones
NúcleoInterfaz de usuario general

casilla de verificación: seleccione esta opción para mostrar la ruta completa al origen de datos de vídeo en la barra de título.Display the full path De forma predeterminada, Movie Player muestra un nombre abreviado en la barra de título.

NúcleoInterfaz de usuario de origen

casilla de verificación: seleccione esta opción para que las teclas de método abreviado de teclado sean conscientes de la selección del modo de reproducción.Keyboard commands respect playback mode Si desactiva esta casilla de verificación, las teclas de método abreviado de teclado se comportan como si el modo de reproducción estuviera establecido en .Forward playRepeatoff

parameter — Especifica el número de fuentes enumeradas en el menú.Recently used sources listFile

FuentesSimulink

casilla de verificación — Debe tener Simulink instalado.Load Simulink model if not open

— Líneas de señal solamente o líneas y bloques de señal.Connect scope on selection of: Debe tener instalado Simulink.

FuentesArchivo

parámetro: especifique el directorio que se muestra en el cuadro de diálogo Conectar a archivo al hacer clic en .Default open file pathFile > Open

FuentesTrabajo

No hay opciones asociadas a esta selección.

VisualesVideo

No hay opciones asociadas a esta selección.

HerramientasHerramienta Imagen

casilla de verificación: abre un nuevo Visor de imágenes para cada fotograma exportado.Open new Image Tool window for each export

HerramientasRegión de píxeles

No hay opciones asociadas a esta selección.

HerramientasHerramientas de navegación de imágenes

No hay opciones asociadas a esta selección.

HerramientasConjuntos de instrumentación

No hay opciones asociadas a esta selección.

Guardar configuración de la aplicación Del Visor de imágenes

Para guardar los ajustes de configuración para su uso futuro, seleccione File > Configuration Set > Save as.

Nota

De forma predeterminada, el Visor de vídeo utiliza los valores de configuración del archivo .implay.cfg Si desea almacenar la configuración en este archivo, primero debe crear una copia de seguridad del archivo.

Especificar la velocidad de fotogramas

Para reducir o aumentar la velocidad de reproducción, seleccione en el menú Reproducción o utilice el método abreviado de teclado .Frame RateT El cuadro de diálogo Velocidad de fotogramas muestra la velocidad de fotogramas del origen, le permite cambiar la velocidad a la que la aplicación Visor de vídeo reproduce la secuencia de imágenes o el vídeo y muestra la velocidad de reproducción real. Es el número de fotogramas que procesa el Visor de vídeo por segundo.tasa de reproducción

Si desea aumentar la velocidad de reproducción real, pero el hardware del sistema no puede mantenerse al día con la velocidad deseada, active la casilla de verificación.Allow frame drop to achieve desired playback rate Este parámetro permite a la aplicación Visor de vídeo alcanzar la velocidad de reproducción soltando fotogramas. Al seleccionar esta opción, el cuadro de diálogo Velocidad de fotogramas muestra varias opciones adicionales que puede utilizar para especificar las velocidades de actualización mínima sin al menor y máximo. Si su hardware lo permite, aumente la frecuencia de actualización para lograr una reproducción más fluida. Sin embargo, si especifica un rango pequeño para la frecuencia de actualización, la programación de reproducción de fotogramas calculados puede dar lugar a una reproducción entrecortada y aparecerá una advertencia.

Especificar mapa de color

Para especificar el mapa de colores que se aplicará a los valores de intensidad, seleccione en el menú Herramientas o utilice el método abreviado de teclado .ColormapC El Visor de vídeo muestra un cuadro de diálogo que le permite cambiar el mapa de colores.

Utilice el parámetro para especificar un mapa de colores determinado.Colormap

Si sabe que los valores de píxel no utilizan todo el intervalo de tipos de datos, puede activar la casilla de verificación e introducir el intervalo de los datos.Specify range of displayed pixel values El cuadro de diálogo muestra automáticamente el rango en función del tipo de datos de los valores de píxel.

Obtener información sobre una secuencia de imágenes

Para ver información básica sobre los datos de imagen, haga clic en el botón Información de vídeoen la barra de herramientas del Visor de vídeo o seleccione en el menú Herramientas.Video Information El Visor de vídeo muestra un cuadro de diálogo que contiene información básica sobre la secuencia de imágenes, como el tamaño de cada fotograma, la velocidad de fotogramas y el número total de fotogramas.