Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

fvtool

Abra herramienta de visualización de filtros

Sintaxis

fvtool(b,a)
fvtool(sos)
fvtool(d)
fvtool(b1,a1,b2,a2,...,bN,aN)
fvtool(sos1,sos2,...,sosN)
fvtool(Hd)
fvtool(Hd1,Hd2,...,HdN)
h = fvtool(...)

Descripción

fvtool(b,a) abre FVTool y muestra la respuesta de magnitud del filtro digital definido con numerador y denominador,.ba Con FVTool puede visualizar la respuesta de fase, el retardo de grupo, la respuesta de impulso, la respuesta de paso, el trazado de polos cero y los coeficientes del filtro. Puede exportar la respuesta mostrada a un archivo con File > Export.

Nota

Si la entrada es de precisión única, la respuesta de magnitud se calcula utilizando la aritmética de precisión simple.fvtool

fvtool(sos) abre FVTool y muestra la respuesta de magnitud del filtro digital definido por la matriz-by-6 de secciones de segundo ordenL

sos=[b01b11b211a11a21b02b12b221a12a22b0Lb1Lb2L1a1La2L].

Las filas de sos contienen los coeficientes de numerador y denominador Bik Y Unik de la cascada de secciones de segundo orden de ():Hz

H(z)=gk=1LHk(z)=gk=1Lb0k+b1kz1+b2kz21+a1kz1+a2kz2.

El número de secciones, debe ser mayor o igual que 2.L Si el número de secciones es menor que 2, considera que la entrada es un vector de numerador.fvtool

fvtool(d) abre FVTool y muestra la respuesta de magnitud de un filtro digital,.d Se utiliza para generar según las especificaciones de frecuencia-respuesta.designfiltd

fvtool(b1,a1,b2,a2,...,bN,aN) abre FVTool y muestra las respuestas de magnitud de varios filtros definidos con numeradores,,..., y denominadores,,...,.b1bNa1aN

fvtool(sos1,sos2,...,sosN) abre FVTool y muestra las respuestas de magnitud de varios filtros definidos con matrices de sección de segundo orden,,,...,.sos1sos2sosN

fvtool(Hd) abre FVTool y muestra las respuestas de magnitud para el objeto de filtro, o la matriz de objetos de filtro.dfiltHddfilt

fvtool(Hd1,Hd2,...,HdN) abre FVTool y muestra las respuestas de magnitud de los filtros en los objetos,....dfiltHd1Hd2HdN

Si tiene instalado el producto, también puede utilizar y analizar:DSP System Toolbox™fvtool(H)fvtool(H1,H2,...)

y los objetos del sistema admiten FVTool.dsp.DigitalDownConverterdsp.DigitalUpConverter Debe pasar la entrada a la FVTool cuando se llama a FVTool en estos objetos del sistema.'Arithmetic'

Cuando el filtro de entrada es un objeto, FVTool realiza un análisis de punto fijo si se establece la propiedad aritmética del objeto de filtro.dfilt'fixed' Sin embargo, para filtrar objetos de sistema, analiza, en función de la aritmética especificada en la entrada.fvtool(H,'Arithmetic',ARITH,...)HARITH

puede ser uno de, o.ARITH'double''single''fixed' La entrada sólo es relevante para el análisis de objetos del sistema de filtro.'Arithmetic' La configuración aritmética, se aplica a todos los objetos de sistema de filtro que se introduce en FVTool.ARITH Cuando se especifica o, la función realiza un análisis de precisión doble o simple.'double''single' Cuando se especifica, la aritmética cambia en función de la configuración de la propiedad y si el objeto System está bloqueado o desbloqueado.'fixed'CoefficientDataType

 Detalles de aritmética de punto fijo

Si no especifica la aritmética para estructuras que no son de CIC y el objeto System está en estado desbloqueado, la función utiliza aritmética de precisión doble. Si el objeto System está bloqueado, la función realiza un análisis basado en el tipo de datos de entrada bloqueado. Las estructuras CIC sólo soportan aritmética de punto fijo.

Métodos de análisis y tienen restricciones de comportamiento.noisepsdfreqrespestfvtool Para ver las reglas, haga clic en los vínculos a estos métodos.

h = fvtool(...) Devuelve un identificador de figura.h Puede usar este identificador para interactuar con FVTool desde la línea de comandos. Ver.Controlando FVTool desde la línea de comandosMATLAB

FVTool tiene dos barras de herramientas.

  • Una versión extendida de la barra de herramientas de edición de trazado.MATLAB® En la tabla siguiente se muestran los iconos de la barra de herramientas específicos de FVTool.

    Icono

    Descripción

    Restaurar vista predeterminada. Esta vista muestra las regiones de búfer alrededor de los datos y solo muestra datos significativos. Para ver la respuesta mediante el trazado estándar, que muestra todos los valores de datos, utiliceMATLAB View > Full View.

    Alternar leyenda

    Alternar cuadrícula

    Vincular a (aparece sólo si se ha iniciado FVTool)Diseñador de filtrosDiseñador de filtros


    Alternar modo agregar/reemplazar (aparece sólo si se lanzó FVTool desde)Diseñador de filtros

  • Barra de herramientas de análisis con los siguientes iconos

    Respuesta de magnitud del filtro actual. Consulte y para obtener más información.freqzzerophase

    Para ver la respuesta de fase cero, haga clic con el botón derecho en la etiqueta del eje del trazado de magnitud y seleccione en el menú contextual.yZero-phase

    Respuesta de fase del filtro actual. Consulte para obtener más información.phasez

    Superpone la respuesta de magnitud y la respuesta de fase del filtro actual. Consulte para obtener más información.freqz

    Muestra el retardo de grupo del filtro actual. El retardo de grupo es el retardo medio del filtro en función de la frecuencia. Consulte para obtener más información.grpdelay

    Muestra el retardo de fase del filtro actual. El retardo de fase es el retardo de tiempo que el filtro impone en cada componente de la señal de entrada. Consulte para obtener más información.phasedelay

    Respuesta de impulso del filtro actual. La respuesta de impulso es la respuesta del filtro a una entrada de impulso. Consulte para obtener más información.impz

    Respuesta de paso del filtro actual. La respuesta del paso es la respuesta del filtro a una entrada de paso. Consulte para obtener más información.stepz

    Trama de polo cero, que muestra el polo y cero ubicaciones del filtro actual en el plano.z Consulte para obtener más información.zplane

    Los coeficientes de filtro del filtro actual, que dependen de la estructura del filtro (por ejemplo, forma directa, celosía, etc.) en un cuadro de texto. Para los filtros SOS, cada sección se visualiza como un filtro separado.

    Información detallada del filtro.

Vinculación al diseñador de filtros

En la aplicación, seleccioneDiseñador de filtros View > Filter Visualization Tool o el botón de la barra de herramientasFull View AnalysisCuando se muestra un análisis se inicia FVTool para el filtro actual. Puede sincronizar y FVTool con el botón de la barra de herramientasDiseñador de filtros. Los cambios realizados en el filtro se reflejan inmediatamente en FVTool.Diseñador de filtros

Dos modos de enlace se proporcionan a través del botón de barra de herramientas/:

  • Reemplazar: elimina el filtro que se muestra actualmente en FVTool e inserta el nuevo filtro.

  • Añadir: conserva el filtro que se muestra actualmente en FVTool y añade el nuevo filtro a la pantalla.

Modificación de los ejes

Puede cambiar las unidades o ejes haciendo clic con el botón derecho del ratón en la etiqueta del eje o haciendo clic con el botón derecho en el trazado y seleccionando.xyAnalysis Parameters Las opciones disponibles para las unidades de ejes son las siguientes.

conspirarUnidades del eje XUnidades del eje Y

Magnitud

Normalized Frequency
Linear Frequency
Magnitude
Magnitude (dB)
Magnitude squared
Zero-Phase

Fase

Normalized Frequency
Linear Frequency
Phase
Continuous Phase
Degrees
Radians

Magnitud y fase

Normalized Frequency
Linear Frequency

(-eje en el lado izquierdo)y

Magnitude
Magnitude (dB)
Magnitude squared
Zero-Phase

(-eje en el lado derecho)y

Phase
Continuous Phase
Degrees
Radians

Grupo Delay

Normalized Frequency
Linear Frequency
Samples
Time

Fase de retardo

Normalized Frequency
Linear Frequency
Degrees
Radians

Respuesta impulsiva

Samples
Time

Amplitud

Respuesta de paso

Samples
Time

Amplitud

Pole-Zero

Parte real

Parte imaginaria

Modificación de la gráfica

Puede utilizar cualquiera de los botones de la barra de herramientas de edición de trazado para cambiar las propiedades de la gráfica.

son parámetros que se aplican a los análisis mostrados.Analysis Parameters Para mostrarlos, haga clic con el botón derecho en el área de trazado y seleccione en el menú.Analysis Parameters (Tenga en cuenta que solo puede acceder al menú si el botón está inactivo.)Edit Plot Se visualizan los siguientes parámetros de análisis. (Si se visualiza más de una respuesta, se visualizan los parámetros aplicables a cada parcela.) No todos estos campos de análisis se muestran para todos los tipos de trazados:

  • — Si está marcada, la frecuencia se normaliza entre 0 y 1, o si no está marcada, la frecuencia está en HzNormalized Frequency

  • —-escala del eje (o)Frequency ScaleyLinearLog

  • — rango del eje de frecuencia oFrequency RangeSpecify freq. vector

  • — número de muestras utilizadas para calcular la respuestaNumber of Points

  • — vector que se utilizará para el trazado, si está seleccionado.Frequency VectorSpecify freq. vectorFrequency Range

  • —-unidades del eje (,,, o)Magnitude DisplayyMagnitudeMagnitude (dB)Magnitude squaredZero-Phase

  • —-unidades del eje (o)Phase UnitsyDegreesRadians

  • — tipo de gráfica de fase (o)Phase DisplayPhaseContinuous Phase

  • —-unidades del eje (o)Group Delay UnitsySamplesTime

  • — tipo de longitud de la respuesta de impulso o paso (o)Specify LengthDefaultSpecified

  • — número de puntos a utilizar para la respuesta de impulso o pasoLength

Además de los parámetros de análisis anteriores, puede cambiar el tipo de trazado de los trazados de impulso y respuesta de paso haciendo clic con el botón derecho y seleccionando, o desde el menú contextual.Line with MarkerStemLine Puede cambiar las unidades del eje haciendo clic con el botón derecho en la etiqueta del eje y seleccionando o.xxSamplesTime

Para guardar los parámetros mostrados como los valores predeterminados que se usarán cuando o FVTool esté abierto, haga clic en.Diseñador de filtrosSave as default

Para restaurar los valores predeterminados, haga clic en.Restore original defaults

Los consejos de datos muestran información sobre un punto determinado en la gráfica. Consulte para obtener información sobre sugerencias de datos.Explore de forma interactiva los datos trazados (MATLAB)

Si tiene el software, FVTool muestra una máscara de especificación junto con su filtro diseñado en una gráfica de magnitud.DSP System Toolbox

Nota

utilizar View > Passband zoom, el filtro debe haber sido diseñado usando o.fdesignDiseñador de filtros El zoom de banda de paso no se proporciona para los filtros de peine de integración en cascada (CIC) porque CICs no tiene bandas de paso convencionales.

Superponer una respuesta

Puede superponer una segunda respuesta en el trazado seleccionando Analysis > Overlay Analysis y seleccionar una respuesta disponible. Se agrega un segundo eje al lado derecho de la gráfica de respuesta.y El cuadro de diálogo parámetros de análisis muestra los parámetros para el eje y los dos ejes. xy Consulte un cuadro de diálogo parámetros de análisis de ejemplo.Visualizar parámetros de análisis

Controlando FVTool desde la línea de comandosMATLAB

Después de obtener el identificador de FVTool, puede controlar algunos aspectos de FVTool desde la línea de comandos. Además de las propiedades estándar (consulte controlar gráficos en la documentación), FVTool tiene las siguientes propiedades:Handle Graphics®MATLAB

  • : muestra el tipo de trazado de análisis especificado.'Analysis' En la tabla siguiente se enumera todos los tipos de análisis y cómo invocarlos. Tenga en cuenta que los únicos análisis que utilizan los componentes internos del filtro son la estimación de la respuesta de magnitud y la potencia de ruido de redondeo, que solo están disponibles con el producto.DSP System Toolbox

    Tipo de análisisOpción de análisis

    La gráfica de magnitud

    'magnitude'

    La gráfica de fase

    'phase'

    La gráfica de magnitud y fase

    `freq'

    Gráfica de retardo de grupo

    'grpdelay'

    La gráfica de retardo de fase

    `phasedelay'

    Gráfica de respuesta impulsiva

    'impulse'

    Trazado de respuesta de paso

    'step'

    Parcela de polo cero

    'polezero'

    Los coeficientes de filtro

    'coefficients'

    Filtre la información

    'info'

    Estimación de respuesta de magnitud

    (disponible solo con el producto, consulte para obtener más información)DSP System Toolboxfreqrespest

    'magestimate'

    La potencia de ruido de redondeo

    (disponible solo con el producto, consulte para obtener más información)DSP System Toolboxnoisepsd

    'noisepower'

  • : controla si la rejilla es o'Grid''on''off'

  • : controla si la leyenda es o'Legend''on''off'

  • : controla la frecuencia de muestreo de los filtros en FVTool.'Fs' El vector de frecuencia de muestreo debe tener la misma longitud que el número de filtros o un valor escalar. Si se trata de un vector, cada valor se aplica a su filtro correspondiente. Si es un escalar, se aplica el mismo valor a todos los filtros.

  • SosViewSettings — (Esta opción solo está disponible si tiene el producto.)DSP System Toolbox Para los filtros de secciones de segundo orden, esto controla cómo se muestra el filtro. La propiedad contiene un objeto, por lo que debe utilizar esta sintaxis para estableclo:SOSViewSettings set(h.SOSViewSettings,'View',viewtype)Dónde viewtype es uno de los siguientes:

    • : Muestra la respuesta completa del filtro general'Complete'

    • : Muestra la respuesta de cada sección por separado'Individual'

    • ' Acumulado ': muestra la respuesta de cada sección acumulada con cada sección anterior. Si el filtro tiene tres secciones, la primera gráfica muestra la sección uno, la segunda gráfica muestra la acumulación de las secciones una y dos, y la tercera gráfica muestra la acumulación de las tres secciones.

      También puede definir si se debe utilizar, lo que determina dónde se deben dividir las secciones.SecondaryScaling Los puntos de escalado secundarios son las ubicaciones de escalado entre las partes recursivas y no recursivas de la sección. El valor predeterminado es, que no utiliza el escalado secundario.false Para activar el escalado secundario, utilice esta sintaxis:set(h.SOSViewSettings,'View','Cumulative',true)

    • : Permite definir las secciones que se mostrarán y el orden en que se mostrarán.'UserDefined' Escriba una matriz de celdas donde cada sección está representada por su índice. Si introduce un índice, solo se trazará esa sección. Si introduce un rango de índices, se traza la respuesta combinada de ese rango de secciones. Por ejemplo, si el filtro tiene cuatro secciones, al escribir traza la respuesta combinada para las cuatro secciones y al escribir traza la respuesta para cada sección individualmente.{1:4}{1,2,3,4}

Nota

Puede cambiar otras propiedades de FVTool desde la línea de comandos utilizando la función.set Se usa para ver etiquetas de propiedad y la configuración de propiedades actuales.get(h)

Puede utilizar los métodos siguientes con el identificador de FVTool.

agrega un nuevo filtro a FVTool.addfilter(h,filtobj) El nuevo filtro, debe ser un objeto de filtro.filtobjdfilt Puede especificar la frecuencia de muestreo del nuevo filtro con.addfilter(h,filtobj,'Fs',10)

reemplaza el filtro en FVTool con el filtro especificado en.setfilter(h,filtobj)filtobj Puede establecer la frecuencia de muestreo como se describió anteriormente.

elimina el filtro en la ubicación de la matriz de celdas de FVTool.deletefilter(h, index)index

crea una leyenda en FVTool asociando con el filtro 1, con el filtro 2, etc.legend(h,str1,str2,...)str1str2 Consulte la documentación para obtener información.legendMATLAB

Ejemplos

contraer todo

Muestra la respuesta de magnitud de un filtro elíptico de 6º orden. Especifique una ondulación de banda de paso de 3 dB, una atenuación de banda de parada de 50 dB, una frecuencia de muestreo de 1 kHz y un borde de banda de paso normalizado de 300 Hz. Inicie FVTool desde la línea de comandos.

[b,a] = ellip(6,3,50,300/500); fvtool(b,a)

Visualice y analice múltiples filtros FIR, iniciando FVTool desde la línea de comandos.

b1 = firpm(20,[0 0.4 0.5 1],[1 1 0 0]);  b2 = firpm(40,[0 0.4 0.5 1],[1 1 0 0]);  fvtool(b1,1,b2,1)

Visualice los parámetros de análisis asociados.

Inicie FVTool desde la línea de comandos. Muestra la respuesta de magnitud de un filtro elíptico de 6º orden. Especifique una ondulación de banda de paso de 3 dB, una atenuación de banda de parada de 50 dB, una frecuencia de muestreo de 1 kHz y un borde de banda de paso normalizado de 300 Hz.

[b,a] = ellip(6,3,50,300/500); h = fvtool(b,a);

Visualice la respuesta de fase del filtro.

h.Analysis = 'phase';

Active la leyenda de trazado y agregue texto.

legend(h,'Phase plot')

Especifique una frecuencia de muestreo de 1 kHz. Mostrar la respuesta centrada en dos lados.

h.Fs = 1000; h.FrequencyRange='[-Fs/2, Fs/2)';

Ver todas las propiedades de la gráfica. Las propiedades específicas de FVTool se encuentran al final de la lista.

get(h)
                     Grid: 'on'                    Legend: 'on'           AnalysisToolbar: 'on'             FigureToolbar: 'on'                DesignMask: 'off'           SOSViewSettings: [1x1 dspopts.sosview]                        Fs: 1000                  Alphamap: [1x64 double]           CloseRequestFcn: 'closereq'                     Color: [0.9400 0.9400 0.9400]                  Colormap: [64x3 double]               CurrentAxes: [1x1 Axes]          CurrentCharacter: ''             CurrentObject: [0x0 GraphicsPlaceholder]              CurrentPoint: [0 0]              DockControls: 'on'                  FileName: ''             IntegerHandle: 'on'            InvertHardcopy: 'on'               KeyPressFcn: ''             KeyReleaseFcn: ''                   MenuBar: 'none'                      Name: 'Filter Visualization Tool - Phase Response'                  NextPlot: 'new'               NumberTitle: 'on'                PaperUnits: 'inches'          PaperOrientation: 'portrait'             PaperPosition: [1.3350 3.3150 5.8300 4.3700]         PaperPositionMode: 'auto'                 PaperSize: [8.5000 11]                 PaperType: 'usletter'                   Pointer: 'arrow'         PointerShapeCData: [16x16 double]       PointerShapeHotSpot: [1 1]                  Position: [346.5000 282.5000 583 437]                  Renderer: 'opengl'              RendererMode: 'auto'                    Resize: 'on'                 ResizeFcn: ''             SelectionType: 'normal'                   ToolBar: 'auto'                      Type: 'figure'                     Units: 'pixels'       WindowButtonDownFcn: ''     WindowButtonMotionFcn: ''         WindowButtonUpFcn: ''         WindowKeyPressFcn: ''       WindowKeyReleaseFcn: ''      WindowScrollWheelFcn: ''               WindowStyle: 'normal'              BeingDeleted: 'off'             ButtonDownFcn: ''                  Children: [15x1 Graphics]                  Clipping: 'on'                 CreateFcn: ''                 DeleteFcn: ''                BusyAction: 'queue'          HandleVisibility: 'on'                   HitTest: 'on'             Interruptible: 'on'                    Parent: [1x1 Root]                  Selected: 'off'        SelectionHighlight: 'on'                       Tag: 'filtervisualizationtool'             UIContextMenu: [0x0 GraphicsPlaceholder]                  UserData: []                   Visible: 'on'         OverlayedAnalysis: ''            FrequencyScale: 'Linear'                  Analysis: 'phase'            NumberofPoints: 8192           FrequencyVector: [1x256 double]            FrequencyRange: '[-Fs/2, Fs/2)'              PhaseDisplay: 'Phase'       NormalizedFrequency: 'off'             ShowReference: 'on'                PhaseUnits: 'Radians'             PolyphaseView: 'off' 

Introducido antes de R2006a